Как добавить вариант выбора отчета СКД?

В УФ я так понимаю, вариант выбора выводят на форму сама платформа. А вот в 8.2 на обычном режиме приходится делать форму и
На форму отчета кладешь реквизит “ПолеВыбора” с именем “ВариантОтчета”, тип – произвольный.

В модуле формы:

Процедура ПриОткрытии()
 //Заполнение вариантов настроек отчета
 Для Каждого ВариантНастроек Из СхемаКомпоновкиДанных.ВариантыНастроек Цикл
 ЭлементыФормы.ВариантОтчета.СписокВыбора.Добавить(ВариантНастроек.Имя, ВариантНастроек.Представление);
 КонецЦикла;
 Если СхемаКомпоновкиДанных.ВариантыНастроек.Количество() > 0 Тогда
 ЭлементыФормы.ВариантОтчета.Значение = СхемаКомпоновкиДанных.ВариантыНастроек[0].Имя;
 КонецЕсли;
 КонецПроцедуры //ПриОткрытии()

Процедура ВариантОтчетаПриИзменении(Элемент)
 КомпоновщикНастроек.ЗагрузитьНастройки(СхемаКомпоновкиДанных.

ВариантыНастроек.Найти(Элемент.Значение).Настройки);
 КонецПроцедуры //ВариантОтчетаПриИзменении()

One comment on “Как добавить вариант выбора отчета СКД?

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *