Как выгрузить Табели учета рабочего времени в эксель из ЗУПа?

Нужно просто выдрать код из процедуры печати:

Процедура КнопкаВыполнитьНажатие(Кнопка)

Каталог = “c:\выгрузка-табелей\”;


Запрос = Новый Запрос;
Запрос.Текст =  “ВЫБРАТЬ
|    ТабельУчетаРабочегоВремениОрганизации.Ссылка
|ИЗ
|    Документ.ТабельУчетаРабочегоВремениОрганизации КАК ТабельУчетаРабочегоВремениОрганизации
|ГДЕ
|    ТабельУчетаРабочегоВремениОрганизации.Проведен” ;
Выборка = Запрос.Выполнить().Выбрать();
Пока Выборка.Следующий() Цикл
Объект = Выборка.Ссылка.ПолучитьОбъект();

ТабДокумент = Неопределено;

ИмяМакета = “Т13”;
// Получить экземпляр документа на печать
Если ЗначениеЗаполнено(ИмяМакета) Тогда

Если Не Объект.Проведен Тогда
РаботаСДиалогами.ВывестиПредупреждение(“Документ можно распечатать только после его проведения!”);
//Возврат Неопределено;
КонецЕсли;

ОписаниеПечатнойФормы = ТабельУчетаРабочегоВремениОрганизацииПереопределяемый

.ПолучитьОписаниеПечатнойФормы(ИмяМакета);

Если Объект.СпособВводаДанных <> Перечисления.СпособыВводаДанныхОВремени.ПоДням  Тогда
ОбработкаКомментариев = глЗначениеПеременной(“глОбработкаСообщений”);
ОбработкаКомментариев.УдалитьСообщения();
ОбработкаКомментариев.ДобавитьСообщение(“Предупреждение”, Перечисления.ВидыСообщений.Раздел);
ОбработкаКомментариев.ПоказатьСообщения();
КонецЕсли;

Запрос = Новый Запрос;
Запрос.УстановитьПараметр(“ДокументСсылка”, Объект.Ссылка);
Запрос.Текст =
“ВЫБРАТЬ РАЗЛИЧНЫЕ
|    ОтработанноеВремя.Сотрудник
|ИЗ
|    Документ.ТабельУчетаРабочегоВремениОрганизации.ОтработанноеВремя КАК ОтработанноеВремя
|ГДЕ
|    ОтработанноеВремя.Ссылка = &ДокументСсылка
|
|ОБЪЕДИНИТЬ
|
|ВЫБРАТЬ РАЗЛИЧНЫЕ
|    ОтработанноеВремяВЦеломЗаПериод.Сотрудник
|ИЗ
|    Документ.ТабельУчетаРабочегоВремениОрганизации.ОтработанноеВремяВЦеломЗаПериод КАК ОтработанноеВремяВЦеломЗаПериод
|ГДЕ
|    ОтработанноеВремяВЦеломЗаПериод.Ссылка = &ДокументСсылка”;

СписокСотрудников = Запрос.Выполнить().Выгрузить().ВыгрузитьКолонку(“Сотрудник”);

Если ИмяМакета = “Т13” Тогда
ТабДокумент = ФормированиеПечатныхФормЗК.СформироватьПечатнуюФормуТ13(Объект, СписокСотрудников)
КонецЕсли;
КонецЕсли;

ТабДокумент.Записать(Каталог+Объект.Номер+”.xls”, ТипФайлаТабличногоДокумента.XLS);

ОбработкаПрерыванияПользователя();

КонецЦикла;

Сообщить(“Выгрузка завершена”);

КонецПроцедуры

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *