Факториал факториалов

с вложенными циклами и рекурсией:

Процедура ВычислениеФакториала()

    ЧислоФакториал = 6;
    ФакториалОбщий = 1;
    Для Сч = 1 По ЧислоФакториал Цикл
        НовыйФакториал = Факториал(Сч);
        ФакториалОбщий = ФакториалОбщий * НовыйФакториал;
    КонецЦикла;

    Сообщить(ФакториалОбщий);

КонецПроцедуры;

&НаКлиенте
Функция Факториал (К)

   Если К > 1 Тогда
       Возврат К * Факториал(К – 1);
  Иначе
       Возврат 1
  КонецЕсли;

КонецФункции

А проще можно как? =)

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *