Использование своего макета в построителе

Делается это так (виа Миста):

НовыйМакет = ПостроительОтчета.Макет;


//Делаем с НовыйМакет что-нить, меняем ширину колонок, форматы, надписи в шапке и т. д.  

ПостроительОтчета.Макет = НовыйМакет;

//Самое главное, не забыть после вывода построителя или перед строкой НовыйМакет = ПостроительОтчета.Макет;
написать строку
ПостроительОтчета.Макет = Неопределено;
, иначе макет первый раз зафиксируется и больше автогенерироваться не будет :o)

Редактировать ширину колонок после выполнения кода можно так:

//Макет - это макет, полученный из построителя, 
//который мы после редактирования запихнем обратно в построитель 
//Ширина - число, ширина колонки  

Для Каждого ОбластьПоиска Из Макет.Области Цикл

    ТекущаяОбласть = Неопределено;

    Пока Истина Цикл

        ТекущаяОбласть = Макет.НайтиТекст(ПредставлениеКолонки, ТекущаяОбласть, ОбластьПоиска, Истина, Истина, Истина, Ложь);

        Если ТекущаяОбласть <> Неопределено Тогда
            ТекущаяОбласть.ШиринаКолонки = Ширина;
        Иначе
            Прервать;
        КонецЕсли;

    КонецЦикла;

КонецЦикла;

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>