Функция Количество прописью

Функция выводит количество прописью (нужна когда ЧислоПрописью работает, но не совсем). Например если надо 0.42 вывести – как “ноль целых сорок две сотых”

Функция КоличествоПрописью(Количество) Экспорт

ЦелаяЧасть = Цел(Количество);
ДробнаяЧасть = Окр(Количество - ЦелаяЧасть, 3);

Если ДробнаяЧасть = Окр(ДробнаяЧасть,0) Тогда
ПараметрыПрописи = ", , , , , , , , 0";
ИначеЕсли ДробнаяЧасть = Окр(ДробнаяЧасть, 1) Тогда
ПараметрыПрописи = "целая, целых, целых, ж, десятая, десятых, десятых, м, 1";
ИначеЕсли ДробнаяЧасть = Окр(ДробнаяЧасть, 2) Тогда
ПараметрыПрописи = "целая, целых, целых, ж, сотая, сотых, сотых, м, 2";
Иначе
ПараметрыПрописи = "целая, целых, целых, ж, тысячная, тысячных, тысячных, м, 3";
КонецЕсли;

Возврат ЧислоПрописью(Количество, "НП= Истина;НД=Истина;ДП=Истина", ПараметрыПрописи);

КонецФункции

 

 

Как заполнить дополнительное свойство в Бухгалтерии 3.0?

Свойство для реализации называется Схема и имеет значение Блэк. Готовим ТЗ и забрасываем в типовой метод:

ТЗ = Новый ТаблицаЗначений; 
ТЗ.Колонки.Добавить("Свойство"); 
ТЗ.Колонки.Добавить("Значение"); 
НС = ТЗ.Добавить(); 
НС.Свойство = ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("Схема (Реализация (акты, накладные))"); 
НС.Значение = Справочники.ЗначенияСвойствОбъектов.НайтиПоНаименованию("Блэк"); 
УправлениеСвойствами.ЗаписатьСвойстваУОбъекта(ОбъектНазначения.Ссылка, ТЗ);

 

Защита от опасных действий – снимаем галочку

виа Инфостарт

мПользователи = ПользователиИнформационнойБазы.ПолучитьПользователей(); Для Каждого Пользователь из мПользователи Цикл Если Пользователь.ЗащитаОтОпасныхДействий.ПредупреждатьОбОпасныхДействиях Тогда Пользователь.ЗащитаОтОпасныхДействий.ПредупреждатьОбОпасныхДействиях = Ложь; Попытка Пользователь.Записать(); Сообщить("Обработан пользователь: "+Пользователь.Имя); Исключение Сообщить(""+Пользователь.Имя+" : "+ОписаниеОшибки()); КонецПопытки; КонецЕсли; КонецЦикла;