Переименовываем поля в построителе

Полезная процедура из типовых конфигураций. Пояснения в коде.

// Процедура заполняет представления элементов всех коллекций построителя отчета на
 
//  основании соответствия имен и представдлений переданных в параметре
 
//
 
// Параметры
 
//  СтруктураСоответствияИмен - Структура, ключ - имя поля, значение - представление поля
 
//  ПостроительОтчета         - ПостроительОтчета
 
//
 
//  Возвращаемое значение
 
//   НЕТ
 
//
 
Процедура ЗаполнитьПредставленияПолей(СтруктураСоответствияИмен, ПостроительОтчета) Экспорт

    СтруктураКоллекцийПостроителяОтчета = Новый Структура("ДоступныеПоля, ВыбранныеПоля, ИзмеренияКолонки, ИзмеренияСтроки, Отбор");
    
    Для каждого ЭлементСтруктуры Из СтруктураКоллекцийПостроителяОтчета Цикл
        Для а = 0 По ПостроительОтчета[ЭлементСтруктуры.Ключ].Количество() - 1 Цикл
            Если ПустаяСтрока(ПостроительОтчета[ЭлементСтруктуры.Ключ][а].Имя) Тогда
                Продолжить;
            КонецЕсли;
            Если СтруктураСоответствияИмен.Свойство(ПостроительОтчета[ЭлементСтруктуры.Ключ][а].Имя) Тогда
                ПостроительОтчета[ЭлементСтруктуры.Ключ][а].Представление = СтруктураСоответствияИмен[ПостроительОтчета[ЭлементСтруктуры.Ключ][а].Имя];
            КонецЕсли; 
        КонецЦикла; 
    КонецЦикла; 
    
КонецПроцедуры // ЗаполнитьПредставленияПолей()
 

///вызывается при инициализации построителя
 

СтруктураИмен = Новый Структура;
    СтруктураИмен.Вставить("ДатаОтгрузки", "Дата отгрузки");
    СтруктураИмен.Вставить("КоличествоДокумента", "Количество документа");
    СтруктураИмен.Вставить("СуммаДокумента", "Сумма документа");
    СтруктураИмен.Вставить("СостояниеОтгрузки", "Состояние отгрузки");
    СтруктураИмен.Вставить("НомерСчета", "Номер счета");

    ЗаполнитьПредставленияПолей(СтруктураИмен, ПостроительОтчетаОтчет); 

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>