НачатьТранзакцию — ЗафиксироватьТранзакцию

НачатьТранзакцию (BeginTransaction)

Синтаксис:

НачатьТранзакцию(<РежимБлокировок>)

Параметры:

<РежимБлокировок> (необязательный)

Тип: РежимУправленияБлокировкойДанных.
Установка параметра имеет смысл, если для свойства конфигурации "Режим управления блокировкой данных" выбрано значение "Автоматический и Управляемый".
Если значение параметра Автоматический, то данная транзакция будет выполняться в режиме автоматических блокировок.
Если значение параметра Управляемый, то в данной транзакции будут выполняться управляемые блокировки.
Если к моменту вызова данного метода была начата транзакция, выполняющаяся в автоматическом режиме управления блокировками, то установка значения параметра Управляемый не приведет к изменению режима управления блокировками.
Если к моменту вызова данного метода была начата транзакция, выполняющаяся в управляемом режиме блокировок, то установка значения параметра Автоматический приведет к возникновению исключительной ситуации, которая может быть обработана конструкцией Попытка… Исключение… КонецПопытки.
Если для свойства конфигурации "Режим управления блокировкой данных" выбрано значение "Управляемый", то значение параметра по умолчанию Управляемый.
Значение по умолчанию: Автоматический

Описание:

Открывает транзакцию. Транзакция предназначена для записи в информационную базу согласованных изменений. Все изменения, внесенные в информационную базу после начала транзакции, будут затем либо целиком записаны, либо целиком отменены.

Доступность:

Сервер, толстый клиент, внешнее соединение.

Пример:

// Увеличение закупочной цены на 5%
ВыборкаТоваров = Справочники.Номенклатура.Выбрать();
НачатьТранзакцию();
Пока ВыборкаТоваров.Следующий() Цикл
    ТоварОбъект = ВыборкаТоваров.ПолучитьОбъект();
    ЗакупочнаяЦена = ТоварОбъект.ЗакупочнаяЦена;
    Если ЗакупочнаяЦена <> 0 Тогда
        ТоварОбъект.ЗакупочнаяЦена = ЗакупочнаяЦена * 1.05;
        ТоварОбъект.Записать();
    КонецЕсли
КонецЦикла;
ЗафиксироватьТранзакцию();

См. также:

Глобальный контекст, метод ЗафиксироватьТранзакцию
Глобальный контекст, метод ОтменитьТранзакцию

Глобальный контекст.ЗафиксироватьТранзакцию (Global context.CommitTransaction)

Глобальный контекст (Global context)

ЗафиксироватьТранзакцию (CommitTransaction)

Синтаксис:

ЗафиксироватьТранзакцию()

Описание:

Завершает успешную транзакцию. Все изменения, внесенные в информационную базу в процессе транзакции, будут записаны.

Доступность:

Сервер, толстый клиент, внешнее соединение.

Пример:

ЗафиксироватьТранзакцию();

См. также:

Глобальный контекст, метод НачатьТранзакцию
Глобальный контекст, метод ОтменитьТранзакцию

Глобальный контекст (Global context)

ОтменитьТранзакцию (RollbackTransaction)

Синтаксис:

ОтменитьТранзакцию()

Описание:

Отменяет открытую ранее транзакцию. Все изменения, внесенные в информационную базу в процессе транзакции, будут отменены.

Доступность:

Сервер, толстый клиент, внешнее соединение.

Пример:

Если ОбнаруженыОшибки Тогда
    ОтменитьТранзакцию();
КонецЕсли;

См. также:

Глобальный контекст, метод НачатьТранзакцию
Глобальный контекст, метод ЗафиксироватьТранзакцию