Как отобрать документы и выгрузить в табличную часть?

Часто в обработках приходится делать отбор конкретных документов и обрабатывать этот отбор. Вот как может выглядеть отбор заказов поставщику с последующей выгрузкой в табличную часть на форме обработки:

Процедура КнопкаВыполнитьНажатие(Кнопка)
    // Вставить содержимое обработчика.
КонецПроцедуры

Процедура Кнопка1Нажатие(Элемент)

    Выборка = Документы.ЗаказПоставщику.Выбрать(НачДата, КонДата);
    Пока Выборка.Следующий() Цикл
        НовСтр = Заказы.Добавить();
        НовСтр.ЗаказПоставщика = Выборка.Ссылка;
    КонецЦикла;

КонецПроцедуры

Процедура ПериодНажатие(Элемент)

    НастройкаПериода = Новый НастройкаПериода;
    НастройкаПериода.УстановитьПериод(НачДата, КонецДня(КонДата));
    НастройкаПериода.РедактироватьКакИнтервал = Истина;
    НастройкаПериода.РедактироватьКакПериод = Истина;
    НастройкаПериода.ВариантНастройки = ВариантНастройкиПериода.Период;
    НастройкаПериода.Редактировать();
    НачДата = НастройкаПериода.ПолучитьДатуНачала();
    КонДата = НастройкаПериода.ПолучитьДатуОкончания();

КонецПроцедуры

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>