Формирование отчета СКД при открытии

Из книжки Хрусталевой:

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)

Параметры.СформироватьПриОткрытии = Истина;

КонецПроцедуры


&НаСервере
Процедура ПередЗагрузкойВариантаНаСервере(Настройки)

Настройки.ПараметрыВывода.УстановитьЗначениеПараметра("Заголовок",
"Продажа системных блоков");
Настройки.ПараметрыДанных.УстановитьЗначениеПараметра("НачалоПериода",
'20111201');
Настройки.ПараметрыДанных.УстановитьЗначениеПараметра("КонецПериода",
'20111231');

КонецПроцедуры

&НаСервере
Процедура ПередЗагрузкойПользовательскихНастроекНаСервере(Настройки)

Настройки.Элементы[0].Значение = ‘20111201’;
Настройки.Элементы[0].Использование = Истина;
Настройки.Элементы[1].Значение = ‘20111231’;
Настройки.Элементы[1].Использование = Истина;

КонецПроцедуры