Факториал факториалов

с вложенными циклами и рекурсией:

Процедура ВычислениеФакториала()

    ЧислоФакториал = 6;
    ФакториалОбщий = 1;
    Для Сч = 1 По ЧислоФакториал Цикл
        НовыйФакториал = Факториал(Сч);
        ФакториалОбщий = ФакториалОбщий * НовыйФакториал;
    КонецЦикла;

    Сообщить(ФакториалОбщий);

КонецПроцедуры;

&НаКлиенте
Функция Факториал (К)

   Если К > 1 Тогда
       Возврат К * Факториал(К — 1);
  Иначе
       Возврат 1
  КонецЕсли;

КонецФункции

А проще можно как? =)

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.